Upgrading Spree From 1.1.2 to 1.1.3

If you upgraded Spree from 1.1.2 to 1.1.3 and found that the checkout didn’t work with some error about zones

1
2
3
4
ActiveRecord::StatementInvalid (PG::Error: ERROR:  column "zone_members_count" does not exist
LINE 1: ...LECT "spree_zones".* FROM "spree_zones"  ORDER BY zone_membe...
                                                             ^
: SELECT "spree_zones".* FROM "spree_zones"  ORDER BY zone_members_count, created_at):

Then perhaps you missed that you needed to run some migrations

1
2
rake railties:install:migrations
rake db:migrate

Comments